node-glob模块

node-glob模块

node的glob模块允许你使用 *等符号, 来写一个glob规则,像在shell里一样,获取匹配对应规则的文件。这个glob工具基于javascript,它使用了 minimatch 库来进行匹配。下载glob包npm install glob --save-devglob模式语法说明【1】* : 匹配该路径段中0个或多个任意字符//*:匹配路径中某部分:0个或多个字符
浏览:568 标签: glob node 时间: 2018-03-12 16:28
windows系统上nodejs安装及环境配置

windows系统上nodejs安装及环境配置

安装node.js【1】下载地址:https://nodejs.org/dist/ 可选择对应的各种版本;node.js 官网:https://nodejs.org/en/。本次安装node的版本是:node-v6.11.5-x64.msi。【2】安装步骤:直接是“傻瓜式”安装;检测是否安装成功【1】至此Node.js已经安装完成,可以先进行下简单的测试安装是否成功
浏览:603 标签: node windows 时间: 2018-03-07 13:16
通过es-checker检测es6是否支持node当前环境

通过es-checker检测es6是否支持node当前环境

es-checker会检测当前的node版本对es6的支持情况。小编当前的node的版本为:v6.11.0全局安装 es-checkernpm install es-checker -g运行 es-checker 进行检测es-checker运行结果:Variables √let andconst √ TDZ errorfor too-early accesso
浏览:696 标签: es-checker es6 node 时间: 2017-12-28 22:07
npm安装node-sass安装失败的原因及解决办法

npm安装node-sass安装失败的原因及解决办法

        在github克隆项目并用 npm install 初始化的时候,会出现如下报错。        再用 npm run dev 运行项目的时候,会出现如下编译失败的错误。        可见用  npm install 的时候,没有把node-sass安装成功;有时候手动安装node-sass(npm install node-sass --save-d
浏览:1159 标签: node-sass npm node 时间: 2017-12-04 14:33
Linux下安装nodejs及配置环境变量

Linux下安装nodejs及配置环境变量

1、下载对应的node版本,(我下载的是node-v6.11.4-linux-x64.tar.gz)        首先去官网下载代码,这里一定要注意安装分两种,一种是Source Code源码,一种是编译后的文件。提供下载地址:https://nodejs.org/dist/v6.11.5/2、解压 node-v6.11.4-linux-x64.tar.gztar
浏览:557 标签: nodejs linux 时间: 2017-10-24 14:35
express的debug调试/静态资源配置/express应用生成器

express的debug调试/静态资源配置/express应用生成器

debug日志文件的设置:set debug=express:* node server.js,* 是代表所有。然后运行server.js文件:node server.js静态资源配置express应用生成器通过应用生成器工具 express 可以快速创建一个应用的骨架。通过如下命令安装:npm install express-generator -g-h 选项
浏览:516 标签: express 时间: 2017-09-17 20:39
express中的模板引擎/body-parser

express中的模板引擎/body-parser

表单get提交:通过 req.query.?? 来获取对应的值index.html<form action="/add" method="get"> 姓名:<input type="text" name="name"><br /><inputtype="submit"value="提交"></form>server.jsvar express =require('expr
浏览:564 标签: 模板引擎 express body-parser 时间: 2017-09-17 20:28
express中router模块化生产/路劲传值

express中router模块化生产/路劲传值

server.js定义路劲的时候,竟然不要用use,use定义路劲只应用于中间件模块;app.use('/book',router) //router.js中模块的根目录,其实是这里定义的路劲就是模块的根路径。相当于访问 '/book' 的时候,就会去router.js中去匹配 '/' ;访问 '/book/menvscode' 的时候,就会去router.js中去匹配 /m
浏览:522 标签: router express 模块化 时间: 2017-09-17 17:46
express中的响应方式res

express中的响应方式res

send()方法app.get('/',function(res,req){ res.send('menvscode.com');})setHeader方法:在发送报文之前,给报文加上一个识别,下面这些代码作用是可以跨域了。//all()方法:所有来源的客户端,都加上下面的前缀(头部)//setHeader(),在发送报文之前,给报文加上一个识别,下面这些代码作用是可以跨
浏览:525 标签: express 时间: 2017-09-17 16:10
express中路劲简单匹配

express中路劲简单匹配

        其中,app.get( '/',fn(req,res){} )中的函数参数默认自带next参数,若没有匹配当前的路劲,那么就会自行往下运行其他代码。var express =require('express');var app = express();var server = app.listen(3000,function(){console.log('wai
浏览:510 标签: 路由 express 时间: 2017-09-16 22:25
express的安装/项目的初始化

express的安装/项目的初始化

       项目的初始化:npm init -y       安装express:npm install express --save-dev        在安装过程由于疏忽,报了一个错误,已决解,具体详情可以参见这篇文章:menvscode.com/detail/59bd09623bb2bd430d7a7e26        安装成功的截图:        创
浏览:509 标签: express 时间: 2017-09-16 21:29
解决安装express出现的问题:Refusing to install express as a dependency of itself

解决安装express出现的问题:Refusing to install express as a dependency of itself

        在通过 npm install express --save-dev 命令安装express的时候,报如下的错误,这是因为你的项目名称和所安装包的名称冲突了。通过修改项目的文件名称后,重新安装还是会下面的。这个时候很多人都会忽视在通过 npm init -y 初始化项目后,生成的 package.json 文件中有一个 name 的字段,name 的值就是此时项
浏览:1440 标签: express 时间: 2017-09-16 19:22

邮箱快速注册

忘记密码